Web Browser Requirements

Recommended Internet Browsers: To take advantage of the latest online technologies, Provider Express has changed its recommendations for Internet browsers to coincide with the continuous updating of the various browsers. Provider Express recommends PC users should use Internet Explorer version 8.0 or higher, more recent versions of Mozilla Firefox or Google Chrome. MAC users should use Safari.

Due to the highly sensitive nature of medical information, we require that all of our clinicians use a browser that supports 128-bit encryption. The 128-bit browser offers the highest level of encryption available and provides the best protection when transmitting confidential data over the Internet.

How do I find out if my browser has 128-bit Encryption?

If you have Internet Explorer:

  1. Click Help in the I.E. Menu
  2. Click About Internet Explorer
  3. In the section marked Cipher Strength it will say 128-bit if you have a 128-bit secure browser.

Please keep in mind that these instructions are provided as a courtesy to you. Changes in Internet Explorer and other browsers are beyond our control.